MacInTouch Amazon link...

macOS 10.14 Mojave

Channels
Apple
Did Apple remove the ability for F12 to function as the eject key (along with other related commands) on non-Apple keyboards?

I used to use Command-Control-F12 to restart, but that doesn't work under Mojave. It worked under Yosemite...
 


Well, I was surprised by a "Brother Printer Software Update" (v 4.1.1) from Mojave's Software Update. The provided link to the Apple support page showed printer and scanner support for my Brother DCP-9045CDN (v. 4.5.2 shown, whatever that means). After installation, I clicked on the "+" in System Preferences -> Printers & Scanners and I was able to add the Brother multi-function scanner. Previously, as I posted above, that was not working in Mojave.

It works now, and with no black bars, but in the process I had deleted the printer from System Preferences, thinking it was best to add it back fresh. However, I realized that I can no longer add the printer as a Bonjour printer. In fact, clicking on the "+" only shows Bonjour scanners. No printers at all.

I also had this problem with a Brother HL-5370DW printer and had to set it up as a line printer daemon (lpd). I just did the same for the DCP-9045CDN.

Maybe this is an issue with Bonjour routing on the network where I work, but it all seemed to work fine previously. I don't know why scanners would be visible and not printers (different ports, I suppose).

I still maintain that Apple and Mojave have made these kinds of things harder to do than in the past.
 


I used to use Command-Control-F12 to restart, but that doesn't work under Mojave. It worked under Yosemite...
You can add such a keyboard shortcut in System Preferences > Keyboard > Shortcuts.

Do it for "All Applications" for the menu "Restart..." or perhaps "Restart".

Works for me anyway.
 


... Maybe this is an issue with Bonjour routing on the network where I work, but it all seemed to work fine previously. I don't know why scanners would be visible and not printers (different ports, I suppose). I still maintain that Apple and Mojave have made these kinds of things harder to do than in the past.
I have a Brother Hl-L5100DN with macOS 10.14.4, and it shows up as Bonjour on an Ethernet network.
 


When I updated a 2018 Mac Mini to macOS 10.14.5 today, there appeared to be many restarts, but I never heard a boot chime. I used LockRattler to initiate the Gatekeeper update from 165 to 166.

On a 2016 MacBook Pro, updated from the macOS 10.14.5 beta shortly after the Mac Mini update, Gatekeeper 166 was there.

Both machines seem to be happy with their updates to macOS 10.14.5.
 



When I updated a 2018 Mac Mini to macOS 10.14.5 today, there appeared to be many restarts, but I never heard a boot chime. I used LockRattler to initiate the Gatekeeper update from 165 to 166.

On a 2016 MacBook Pro, updated from the macOS 10.14.5 beta shortly after the Mac Mini update, Gatekeeper 166 was there.

Both machines seem to be happy with their updates to macOS 10.14.5.
For systems that normally play a boot chime, it is temporarily turned off when running macOS updates. This has been going on since High Sierra and possibly earlier. Here's a post about updating High Sierra with Security Update 2018-002 - no boot chime during update back then.

Also, for anyone who missed it, here are instructions on how to display the standard Installer window during macOS updates instead of the black screen with the time remaining progress bar.
 


Well here I sit booted into my wife's iMac via my Mac Pro's Sierra SSD, including yesterday's latest updates. Backed it up just prior to attempting to update the Mojave SSD from 10.14.4 to 10.14.5 through Software Update. Apparently got a bit too brave, and let the installer run while I hopped in shower, and when I got back to the Mac Pro (tower) it was just sitting there doing nothing, black screen. After quite some time of more nothing, I went ahead and powered it off, and tried various things to make something different happen, but no go.

Basically, now it just powers up, steady white light, the spinning disks spin, the USB mouse lights up then it just sits there, no monitor content, no responses to usb keyboard or the mouse. So the lights are on, but nobody's home.

Any suggestions? (Prior to the upgrade attempt I was sitting at firmware 141.0.0.0.0 and had managed to get a seemingly properly functioning macOS 10.14.4 installed but did not really use it much). Now, who knows if there's even any firmware in place.) A few times I did try holding the power button down until the white light started flashing, but that didn't make a difference either, by the way. Nor is there any response to held down D, S, or Option keys during startup.

Is it a boat anchor now, or is there some way to get it back? (Theoretically it's not really supported by Apple any more, it was originally an early 2009 model, so...).
 


Ric Ford

MacInTouch
Well here I sit booted into my wife's iMac via my Mac Pro's Sierra SSD, including yesterday's latest updates. Backed it up just prior to attempting to update the Mojave SSD from 10.14.4 to 10.14.5 through Software Update. Apparently got a bit too brave...
Is it a boat anchor now, or is there some way to get it back? (Theoretically it's not really supported by Apple any more, it was originally an early 2009 model, so...).
I wonder if this is related?
Eclectic Light Co. said:
Mojave 10.14.5 changes kernel extension security
Tucked away in the macOS Mojave 10.14.5 update is a significant change in the way that it handles third-party kernel extensions. The only outward sign is a change in the version number of its KEXT block extension, AppleKextExcludeLList.kext in /System/Library/Extensions, bringing it to version 14.5.1.

Apple had previously warned third-party developers of kernel extensions that, in addition to their special signing certificates, all updated and new kernel extensions would need to be notarized by Apple. What has happened inside AppleKextExcludeLList.kext shows how great this change is proving to be.
 


Ric Ford

MacInTouch
More details from Howard Oakley on the latest update:
Eclectic Light Co. said:
What has changed in the Mojave 10.14.5 update?

... There are EFI firmware updates apparently for all Mojave-capable Mac models, which I have now entered in my article listing current EFI firmware versions.

Among the major apps to be replaced are:
  • App Store, remaining at version 3.0, now build 1003.3.
  • Automator, 2.9 build 444.42.
  • Books, 1.19 build 1645.
  • Calculator, 10.14 build 123.
  • Calendar, 11.0 build 2245.5.2.
  • Contacts, 12.0 build 1894.
  • FaceTime, 5.0 build 3080.
  • iTunes, which is accompanied by a second update to address potential issues in syncing iOS devices with the iTunes app, version 12.9.5.5.
  • Mail, 12.4 build 3445.104.11.
  • Maps, 2.1 build 2132.25.12.18.12.
  • Messages, 12.0 build 5500.
  • News, which has some improvements for the News+ service where it’s available, version 4.3.
  • Photos, 4.0 build 3451.7.120.
  • Preview, 10.1 build 944.6.16.1.
  • Safari, which fixes many WebKit bugs and changes to version 12.1.1 build 14607.2.6.1.1.
  • VoiceMemos, 2.0.
  • Activity Monitor, 10.14.
  • Console, 1.1 build 3.0.17.
  • Disk Utility, 18.0 build 1667.3.
  • Terminal, 2.9.5 build 421.2.
In the system folders, the greatest volume of replacement files is in the /System/Library folder, which accounts for almost 5 GB of the installed update.
  • /bin and /sbin have many replacement tools.
  • Marzipan support is extensively updated.
  • Automator actions are largely replaced.
  • Most of the tools and components in CoreServices are replaced, although most don’t appear to be new versions as such.
  • All Apple kernel extensions appear to be replaced.
  • AppleKextExcludeList.kext gains a new Property List, ExceptionsLists.plist, as part of the changes in KEXT security.
  • Fonts updated include Apple Color Emoji and Apple Symbols.
  • Most public and private frameworks are replaced.
  • Much of the contents of the folders within /usr are replaced, including many of the tools in /usr/bin and /usr/sbin.
APFS has been updated from version 945.250.134 in 10.14.4 to version 945.260.7, which is another small increment comparable in distance the last update, but includes new versions of all the file system’s command tools.
 


.. the lights are on, but nobody's home.
Any suggestions? (Prior to the upgrade attempt I was sitting at firmware 141.0.0.0.0 and had managed to get a seemingly properly functioning macOS 10.14.4 installed but did not really use it much). Now, who knows if there's even any firmware in place.) A few times I did try holding the power button down until the white light started flashing, but that didn't make a difference either, by the way. Nor is there any response to held down D, S, or Option keys during startup.
Is it a boat anchor now, or is there some way to get it back? (Theoretically it's not really supported by Apple any more, it was originally an early 2009 model, so...).
I can think of two firmware-related things to try. First, if you didn't also hear a long low tone when you held the power button down to enter firmware update mode (the "lights flashing") try holding the button down past the lights flashing part until you hear the tone. Some Mac Pros aren't actually in EFI update mode until both of these things have happened.

If that doesn't help, and the problem is that the firmware update went south, you can try to recover from the failed update through a firmware recovery process. This post from Howard Oakley will point you in the right direction. The only thing I'm uncertain about is that, since it sounds like you have a 4.1->5.1 upgraded Mac Pro, I'm not sure whether you'd want a 4,1 or a 5,1 recovery CD. I think 5,1, but maybe someone else can advise.
 


That was some promising advice, John. But unfortunately it's basically (still) flashing lights after a while but no tone(s) regardless of how long I hold the power button afterward.

Since then, I tried the EFI Restoration CD approach, but CD player is unresponsive (the drawer doesn't pop out when it should, apparently after those blinking lights). And I also tried loading the CD beforehand, again nothing. Tried both the 4,1 (had one semi-handy) and the 5,1 recovery CDs. So, CDs and maybe the hard disks do seem to start up and reach speed, but that's all. (Next stop: older graphics card.)
 



I have a Synology NAS attached to a Mac Pro 5.1 After I updated Mojave to 10.14.5, I could no longer mount the NAS using either SMB or AFP. There's no error message, the Finder just hangs on the dialog. I reverted to macOS 10.14.4 (thank you, Carbon Copy Cloner), and the problem disappeared.

Has anyone else experienced this problem? If so, is there a fix?
 


Since then, I tried the EFI Restoration CD approach, but CD player is unresponsive (the drawer doesn't pop out when it should, apparently after those blinking lights). And I also tried loading the CD beforehand, again nothing. Tried both the 4,1 (had one semi-handy) and the 5,1 recovery CDs. So, CDs and maybe the hard disks do seem to start up and reach speed, but that's all. (Next stop: older graphics card.)
Classic Mac Pros (i.e. not trash can) do not have firmware updates automatically applied. You have to run a full macOS installer, and it tells you that the firmware needs to be updated upon launch of the installer. If you didn't see that screen (because you used Software Update or ran an Updater (Combo or Delta)), then no firmware update happened.

What graphics card do you have in there? I have an Nvidia that requires the web drivers, and I find that the Security/Point Update process these days takes almost an hour, most of it with an entirely black screen, and then I have to use Remote Desktop when it's done to install the latest web drivers.

What is the exact power-on sequence you see? Press power button, light comes on, fans come on, after X seconds, light starts blinking fast? slow?
 


What graphics card do you have in there? I have an Nvidia that requires the web drivers, and I find that the Security/Point Update process these days takes almost an hour, most of it with an entirely black screen, and then I have to use Remote Desktop when it's done to install the latest web drivers.
What is the exact power-on sequence you see? Press power button, light comes on, fans come on, after X seconds, light starts blinking fast? slow?
The graphics card I went with was a (used) Radeon HD 7950. Didn't have to do anything special with it; it came Mac-compatible (boot screen and all) and does Metal.

The exact power-on sequence is
  1. press power button,
  2. light comes on (including the one in the wired mouse),
  3. fans come on,
  4. the hard disks spin up, and the SuperDrive does too, then it just sits.
  5. A little while later the disks and the SuperDrive spin down.
The fans keep running at normal speed. Nothing at all has shown up on the video display throughout, nor has there been any audio. And I can't do a thing with it after that, nor does anything change after letting it sit for a few hours.

If I start it up from scratch and keep my finger on the power button, most/all of that still happens, and after a little bit the white light will quickly flash, but nothing beyond that (no beep or any other sounds), and no apparent other activity (like the superdrive drawer popping out).

So, really can't do a thing with it. (The older graphics card didn't change anything.)

I did have a pretty tough time getting to macOS 10.14.4 (from 10.14.3), but I did manage to get there eventually after trying a number of different things. What finally got me to where I wanted to be started with cloning my everyday Sierra SSD (with all the latest updates) to the target SSD, then installing High Sierra on top of that and doing all of the corresponding Apple updates, then finally installing Mojave on top of that and doing all those updates. (The firmware had already been updated to 141.0.0.0 at some point prior to doing all of that, during one of the High Sierra installs that had happened previously to try to figure out how to get things working properly.) Apparently that's what I should have done for 10.14.5 as well, rather than just doing the software update, but...
 


I have a Synology NAS attached to a Mac Pro 5.1 After I updated Mojave to 10.14.5, I could no longer mount the NAS using either SMB or AFP. There's no error message, the Finder just hangs on the dialog. I reverted to macOS 10.14.4 (thank you, Carbon Copy Cloner), and the problem disappeared. Has anyone else experienced this problem? If so, is there a fix?
I have SMB shares from both a Time Capsule and a Mac Mini that are mounting with no problems under macOS 10.14.5. I am mounting them w/ AppleScript, rather than Finder, FWIW.
 


I have a Dell U2415 [display] connected to an OWC 14-port Thunderbolt 3 dock that is connected to the 2018 MacBook Pro 15" (model 15,3 with Radeon Pro Vega 20).

Prior to macOS 10.14.5, the U2415 came on as it is supposed to on a bootup and restart. Now it comes on with a normal boot, but on a 'restart' it does not, and the MacBook Pro will not recognize it, no matter what sort of futzing I do with it, including using the USB-C video adapter.

Oddly, on a hunch on a restart I pulled the Mini DisplayPort plug from the OWC dock and plugged it back in after the progress bar started, and the U2415 lights up. Weird.
 


I just recently updated my 2018 Mac Mini to macOS v10.14.5. Since doing so, both VirtualBox and Parallels are broken. Both worked fine until the update. Now both error out upon starting with some error message pertaining to kernel mode.
 


I just recently updated my 2018 Mac Mini to macOS v10.14.5. Since doing so, both VirtualBox and Parallels are broken. Both worked fine until the update. Now both error out upon starting with some error message pertaining to kernel mode.
I am running macOS 10.14.5 on a MacBook Pro and trashcan Mac Pro, and both are running Parallels 13.3.2 without any problems. Upon first start, Parallels asked for permission to control my Mac, which I granted. (System Preferences > Security > Privacy > Accessibility. Make sure Parallels is there and the box is checked.)
 



I just recently updated my 2018 Mac Mini to macOS v10.14.5. Since doing so, both VirtualBox and Parallels are broken. Both worked fine until the update. Now both error out upon starting with some error message pertaining to kernel mode.
One of the above articles from The Eclectic Light Co. has a comment that mentions VirtualBox 6.0.8 didn't work with macOS 10.14.5, but the older VirtualBox 6.0.6 did work.
 


I am running macOS 10.14.5 on a MacBook Pro and trashcan Mac Pro, and both are running Parallels 13.3.2 without any problems. Upon first start, Parallels asked for permission to control my Mac, which I granted. (System Preferences > Security > Privacy > Accessibility. Make sure Parallels is there and the box is checked.)
I tried that, but it still errors out. I'm restoring my Mac Mini to macOS 10.14.4 from a Carbon Copy Clone backup. We'll see....
 


I am running macOS 10.14.5 on a MacBook Pro and trashcan Mac Pro, and both are running Parallels 13.3.2 without any problems. Upon first start, Parallels asked for permission to control my Mac, which I granted. (System Preferences > Security > Privacy > Accessibility. Make sure Parallels is there and the box is checked.)
Same experience.
 


An old 2011 MacBook Pro was running El Capitan [OS X 10.11], and the App Store offered Mojave. I approved. After the installation, the Mac was unbootable.
I then checked the Mojave system requirements at Apple and found that this machine (ID 8,1) can only go as far as High Sierra. Luckily the data was recoverable. I'll do a wipe and clean High Sierra install, then bring the data back. Then it's the slog through the final config for printer, wifi, extra apps, etc.
Thanks a lot, Apple.
This might help: macOS Mojave Patcher. However, if you decide to use the patcher, SIP will be disabled. Good luck.
 



This might help: macOS Mojave Patcher. However, if you decide to use the patcher, SIP will be disabled. Good luck.
Thanks, Richard. This particular MacBook Pro is for a client, and I'd prefer to keep it hack-free for the next year until High Sierra no longer gets security updates; then my client can decide whether she wants me to hack it for Mojave or (more likely) just get her a new(er) machine. As she's using it mostly connected to a big-screen TV, we might just get a Mini for her.
 


Anyone have experience with this? I have a MacBook Pro 8,x. The patcher description says 'graphic anomalies' but doesn't sound so bad.
I tried the patch on a 2011 MacBook Pro 17" (8,3 Early or Late, I don't recall, as I have both), and listed in the known issues are graphics anomalies in Light mode. (I did not, and still don't, like dark mode.) It goes on to say "Mojave will be almost UNUSABLE without graphics acceleration. This includes the 15" and 17" MacBook Pro systems (MacBookPro8,2 and 8,3)."

I don't recall, exactly, but since I use a second monitor connected to a CalDidgit dock through Thunderbolt, it may not have been supported.

I just looked for a used 2012 MacBook Pro 15-inch, non-retina for the time being.
 


Amazon disclaimer:
As an Amazon Associate I earn from qualifying purchases.

Latest posts