MacInTouch Amazon link...
I have always had my printers (HP, Epson, and now Canon all-in-ones) configured with WiFi off and connected via Ethernet in various ways to the WiFi router. I can print and scan from any wired or WiFi connected device. I highly recommend it since it is very reliable and avoids another potential WiFi security vulnerability.
The first time my Canon Pro-10 dropped its WiFi connection 90% through a 13x19 print was the last time it was connected wireless.
 


According to HP's support page the most recent firmware for this printer is version 1828A, dated July 31 2018. It sounds like you already have this version, but if you don't, I would start by updating it.
... What kind of Ethernet connection are you talking about?
... Instead, connect your printer's Ethernet port to an Ethernet switch. Connect another port on that switch to your Wi-Fi router (one of its LAN ports). If you like, you can connect other devices (like your desktop computer) to the switch as well.
... If you haven't tried this configuration yet, give it a try. You may need to buy an Ethernet switch if you don't already have one, but they're pretty cheap these days.
Thanks, David, very much for your help. Yes, I've already downloaded the HP driver(s) and reinstalled several times.

I was connecting the printer directly to the iMac using an ethernet cable. Worked great. But, as you say, it disables Airprint and any wifi connection. (Not sure why. Not sure I need to know why.)

I'll have to think about how to use an ethernet switch in my situation. My router is in a different room from the printer and the computers... so running an ethernet cable from the printer to the switch-at-router is physically challenging. But I'll think about how that might be accomplished. (Printer-to-switch-in-same room via ethernet cable. Switch-to-router-in-other-room via CAT-5 in walls. Might be do-able, as long as the switch doesn't have to be in immediate physical proximity to the router.)

Thank you again.
 



... I was connecting the printer directly to the iMac using an ethernet cable. Worked great. But, as you say, it disables Airprint and any wifi connection. (Not sure why. Not sure I need to know why.)
If the iMac and printer are in the same room, can you try using a USB cable?

You could also try a 3rd-party Wifi router (e.g, Linksys), because some ISP routers (e.g, Hitron CGN3 models) don't seem to pass the "Bonjour" traffic to wake up the printer after it has gone to sleep (even if wired with ethernet). So, if you try a different Wifi router (and have both iMac and printer join the network), that would allow to test if the issue is Catalina, or the router.

So the network would look like:
Internet <-> ISP Modem/Router (with wifi turned off) <-> 3rd-Party Router (with NAT, DHCP, and WiFi turned on) <-> your network and devices​

You could also try moving the printer so it is near enough to the router to test it with an ethernet cable, to see if that helps (and if it does, consider running ethernet from the router to the room where the printer belongs).

Connecting the printer to the iMac directly with an ethernet cable is problematic. Ethernet is a network protocol, and both the iMac and printer expect to be given an IP address by a router - without which they won't find each other. When you connect the iMac and printer directly without a router in between, there is no network defined, and the iMac will assign itself an IP address of 169.254.x.x, and the printer may simply ignore the ethernet port. If it worked at all, it would be by accident.

You might also go in to to System Preferences > Printers & Scanners > and delete the instance of the printer, reboot, and then go in and add it again - pay attention to whether it chooses an "Airprint" driver, or an HP driver (both should work, but if it chooses one, try the other...).
 


I'll have to think about how to use an ethernet switch in my situation. My router is in a different room from the printer and the computers... so running an ethernet cable from the printer to the switch-at-router is physically challenging. But I'll think about how that might be accomplished.
Depending in the layout of your home, running cables through the walls might be easy or it might be a really messy procedure.

My first house was a ranch where the basement had a dropped ceiling (meaning I could move tiles for easy access). I ran cables by drilling a hole (inside the wall) through the floor and fished them into the basement. It was pretty easy to pull the cables together to a common location near a power outlet and put a switch there.

My current house, on the other hand, is two stories and the basement is finished with a drywall ceiling. Trying to run cables here would involve opening walls and ceilings and then patching/painting afterward – a job which I will not do.

In order to extend your Ethernet network without running cables through walls, there are a few options you can choose:
With a mesh Wi-Fi solution, you purchase two or more nodes and set them up throughout your house to form a mesh Wi-Fi network. Each node in the network should have at least one LAN-side Ethernet jack. You can attach an Ethernet device or switch to this jack, allowing its wired devices to communicate with everything else in your home.

With a powerline network, you buy two or more adapters and pair them together. You then plug them into power outlets in different rooms in your home. Each one will have at least one Ethernet jack. Plug Ethernet devices or switches into these jacks. The adapters will send Ethernet data over the power lines in your home to establish the network. This is the solution I use in my home.

A MoCA network sends data over the coaxial cable in your walls used for cable TV. Some broadband services (e.g. FiOS) are actually based on MoCA, so you can extend the wired side of your network by simply attaching a compatible transceiver to any room with a cable TV jack. The only catch here is that there are different MoCA frequencies so you need to make sure to get adapters that don't interfere with any other services on the coaxial cable (e.g. cable or satellite TV). Your service provider may be able to help you select compatible adapters.

A HomePNA network is similar to MoCA. It may use coaxial cable or it may use the phone lines in your walls. Like MoCA, you will want to make sure any adapters you get don't interfere with existing services (cable TV, DSL, etc.) Your service provider may be able to help if this interests you.

- - -

As I said above, I'm using powerline networking in my home. This is pretty easy to set up and use. There are a few different standards to choose from. Be sure to select adapters based on the HomePlug AV2 standard. You can get AV2 adapters that (theoretically) can go up to 2 Gbps. In actual practice, you won't come close to that speed, but a fast adapter should give you all the bandwidth you actually require.

My home is using the older HomePlug AV standard with 500Mbps adapters. I've never come close to 500 Mbps, but there is more than enough bandwidth for my 100Mbps cable modem and whatever local LAN connectivity (printing, file sharing) I require.
 


Since my installation of Catalina, I've experienced terrible loss of wifi connections with my HP all-in-one (HP 8620 series) printer/scanner.
… "What's wrong? Download and reinstall software. Connected! Problem solved."
… Rebooting the printer successfully reconnects, but the printer drops the connection again within a few minutes. It's just not practical to have to reboot a printer every time I want to use it.
… I'm wondering whether there's some setting in my wifi router which I could adjust to ensure the router "sees" and "locks in" my printer?
… printer settings to prevent my printer from being "kicked off" after a few minutes of idleness.
Or some way to access the printer's internal settings to …
It seems that the IP address of the printer keeps changing. Installing Catalina might have triggered it, as well as just breathing might do it. I suggest that you consider setting a static IP address for the printer. Then in System Preferences, add the printer as "IP", inputting the static IP address with the Line Printer Daemon protocol. See video on
Assigning Your HP Printer A Static IP Address.
(Note the video uses Windows, but regardless, the information is relevant.

FYI: I used to experience the sudden no-printing as you described, which drove me nuts. So, I set a static IP address for each of my printers.

One other option to consider is restoring network settings to defaults. Hope this helps.
 


It seems that the IP address of the printer keeps changing. Installing Catalina might have triggered it, as well as just breathing might do it. I suggest that you consider setting a static IP address for the printer. Then in System Preferences, add the printer as "IP", inputting the static IP address with the Line Printer Daemon protocol. See video on
(Note the video uses Windows, but regardless, the information is relevant.
FYI: I used to experience the sudden no-printing as you described, which drove me nuts. So, I set a static IP address for each of my printers.
One other option to consider is restoring network settings to defaults. Hope this helps.
I have to agree, and I forgot about this. I have static IP addresses assigned to my Canon all-in-one and our aging HP laser jet.
 


I suggest that you consider setting a static IP address for the printer.
That is a very important thing to do for any device providing server-like capabilities to your network (printers, NASs, etc.)

Just remember to not use an address that might also be assigned by your DHCP server. Your DHCP server is probably running as a part of your router (unless you've disabled it and set up a different one somewhere else). Its configuration should let you specify the range of IP addresses that it hands out (the "dynamic pool") or a range of addresses that it will not hand out (the "static pool"). When creating static addresses for devices, make sure to pick an address in the static pool's range.

FWIW, on my LAN, I reserve a hundred addresses (192.168.1.1 through 192.168.1.100) for my static pool, leaving the rest of the subnet (192.168.1.101 through 192.168.1.254) as the dynamic pool. (Addresses 192.168.1.0 and 192.168.1.255 are reserved for the "null" and "broadcast" addresses. Don't assign them to any devices, ever.)

I configure my major equipment (desktops, laptops, printers and routers) with static addresses in the static pool, leaving everything else (phones, tablets, home appliances, etc.) with dynamic addresses that the DHCP server assigns from the dynamic pool.
 


I want to thank all of you for all this excellent advice! I'm experimenting with several of your suggestions, including setting a static IP address for my printer, switch dispersal of ethernet (Netgear switch arrives today) and "reserving" an address.

I don't use an ISP router; I have my own (Netgear), which works quite well. I have already reset the printer's network settings several times, to factory default, etc. And I have already deleted/re-created the printer in the Mac's printer preference pane, several times, using both Airprint and HP's Bonjour-equivalent software.

Meantime, I'll try not to "breathe" while using Catalina <grin>.

I'll report back. Thank you all, again!
 


That is a very important thing to do for any device providing server-like capabilities to your network (printers, NASs, etc.)

Just remember to not use an address that might also be assigned by your DHCP server. Your DHCP server is probably running as a part of your router (unless you've disabled it and set up a different one somewhere else). Its configuration should let you specify the range of IP addresses that it hands out (the "dynamic pool") or a range of addresses that it will not hand out (the "static pool"). When creating static addresses for devices, make sure to pick an address in the static pool's range.
My, it's all these tasks that some have learned to do over the years that are important...
Access the router LAN TCP/IP setup for a list of the IP addresses dynamically assigned to your devices. That will help in choosing the IP address to assign.
 


Regarding printers and other shared resources, another good reason to use a static IP address (or to have your router assign a "permanent" DHCP address, depending on your preference and your router's capabilities) is to avoid problems with Bonjour and other networking quirks.

For example, some routers will not route Bonjour/mDNS packets between wired and wireless networks or between 2.4GHz and 5GHz wireless networks. For example, if you have one of these routers and you connect your printer wirelessly to your network via the 5GHz band, devices using Bonjour won't be able to reach the printer if they connect through the 2.4GHz wireless band. However, if you use a static/reserved IP address, you'll be able to connect to the printer as an IP printer.

I've seen similar issues (too complicated to go into here) involving IPv6 multicast configuration that blocked some Canon printers from being seen across networks. They were nightmares to troubleshoot, and it was far easier just to use traditional, static/reserved IP addresses.
 


Thanks to your suggestions, my printer connection issues appear to be resolved. Although I did, indeed, install a network switch, I actually believe (after some experimentation) that setting a fixed (static) IP address on the printer, plus "reserving" that same address for the printer in my router were the successful fixes.

These are very simple fixes. I wish I had thought of them. They have obviated the need to hardwire my printer.

Meanwhile, the network switch seems to be behaving very well with my router, and, I feel, has improved the performance of the router itself. I'm not sure why, but perhaps the router was spending too much effort futzing around with my printer.

In any case, thanks again to all of you, not only for your excellent suggestions, but also for "piling on" with extra tips which helped me troubleshoot and repair.
 


There was some discussion in the Catalina section about Dymo label printers, back in January, but this seems more applicable to those of us avoiding macOS 10.15!

I used to keep a Dymo LabelWriter 400 Turbo connected to an old iMac, used as a server and shared over the LAN. Worked perfectly, but when the ten-year-old iMac died, I swapped in an old MacBook Pro. Network printing would now fail, with messages that the print queue was stopped on the server, and the print queue there declared itself unable to read a raster file.

As described in the Catalina thread, I had gone to some trouble to updated the Dymo Label app to the latest 64-bit version, 8.7.3, and this was what was running on the server and the other Macs. Turns out that by downgrading to 8.5.4 on all of them, network printing works once more.

It wouldn't normally have been a great disaster to walk over to the server, open Dymo Label and enter the address and print a label, but my wife and I have each built up over some years our own extensive lists of addressees, and while I can (and have) transferred my address list to the server, I can't combine it with my wife's without a couple of hours of typing.
 


I have two Dymo 450's: a single and a Twin Turbo. My version of Dymo Label software is 8.7.4. My Catalina is macOS 10.15.4.

So far, this combination is running better than any I've used in the past several years. (FWIW and your milage may vary obviously :-)
 


Can anyone recommend app for printing postal envelopes from Mojave or Catalina (i.e. 64-bit)?

I loved SnailMail's simplicity up through El Capitan, but it appears the author has abandoned it at Apple's 32-bit line in the sand.

SnailMail source code was released on GitHub, and I have recompiled it using Xcode for 32-bit successfully, but it errors for 64-bit recompile with messages beyond my code-by-dabble skills.

By chance, has anyone got SnailMail working in 64-bit? If not, has anyone found a simple envelopes tool?
 




Can anyone recommend app for printing postal envelopes from Mojave or Catalina (i.e. 64-bit)?
I loved SnailMail's simplicity up through El Capitan, but it appears the author has abandoned it at Apple's 32-bit line in the sand....
I use EasyEnvelopes in Mojave – it's 64-bit and, since it's still available in the App Store, should work in Catalina. Available from the Mac App Store for $9.99.
 



I still use "EasyEnvelopes" by Ambrosia Software. Still available on the App Store. It's very old (Version 1.0.2 posted 02/12/2013), but it's 64-bit, runs well still, even on Catalina. It's a small, one-trick pony, but does the job nicely. (Just a satisfied user for many years.)
Ralph, I agree the EasyEnvelopes is still a wonderful program and runs well on Catalina. However, I am unable to widen the Addressee field, and somewhat longer first line addresses "line wrap". Any solution to this apparent limitation?
 


I am unable to widen the Addressee field, and somewhat longer first line addresses "line wrap". Any solution to this apparent limitation?
I haven't encountered this problem, but try this:
  1. In the main window, choose the "New Envelope" icon (lower-right).
  2. Once the "new" envelope is open, click the small Lock icon in either (or both) of the main address field or the return address field. Click once to "unlock." This will toggle "auto-centering" off.
  3. Save your new envelope format, giving it a unique name.
  4. Type (or paste) a "long first line" address into the address field. You'll see that the address field expands and slides to accommodate the long address line.
See if that accomplishes what you seek.

Of course, if that doesn't do it, you can always delete the "new" envelope format you created, by selecting it, then pressing Command-Delete.
 


I haven't encountered this problem, but try this:
Ralph: Tried it and even unselected "USPS Guidelines". No dice. But thank you for the tip about using Command-Delete to remove additional templates. I can't help but wonder if this problem arose during Mojave/Catalina. I rarely encounter long addressee names or addresses, so I can't be sure if originally EasyEnvelopes didn't have this limitation. Regardless, much thanks for your advice.
 



However, I am unable to widen the Addressee field, and somewhat longer first line addresses "line wrap". Any solution to this apparent limitation?
For printing envelopes in the Contacts app, the size (and position and font) of the address fields can be set to any size as long as they do not exceed the minimal margins your printer needs.
 


By chance, has anyone got SnailMail working in 64-bit? If not, has anyone found a simple envelopes tool?
Out of curiosity, I was able to compile Snail Mail for 64-bit systems, targeting v10.6. However, someone else has beaten me to it. Visit Godfrey's github Snail Mail fork for updates. I do not have any more info nor have I tested it, but compiling for 64 bits was relatively simple. I am just a curious software programmer.
 


Amazon disclaimer:
As an Amazon Associate I earn from qualifying purchases.

Latest posts